Our team has resolved an issue with a critical piece of infrastructure preventing API calls from succeeding. Doing so has restored the SafetyAmp application and API services to normal operations. We are continuing to monitor the situation to be sure it does not resurface. This incident was preventable. Our dev operations team will be conducting a full post-mortem and implementing failover solutions in an area of our infrastructure where it was missing.
Posted Aug 14, 2025 - 08:17 EDT
Update
We are continuing to investigate this issue.
Posted Aug 14, 2025 - 08:04 EDT
Investigating
We are aware of a US region outage in the SafetyAmp application and API and are all-hands-on-deck in resolving the issue. We will continue to keep you updated.
Posted Aug 14, 2025 - 07:56 EDT
This incident affected: Application and SafetyAmp API.