Some users are receiving an unexpected error message

Incident Report for SafetyAmp

Resolved

This incident has been fully resolved. If you continue experiencing the "An unexpected error has occurred" message, please create a support ticket by e-mailing support@safetyamp.com
Posted May 10, 2022 - 10:58 EDT

Identified

The issue with search has been resolved. The root cause for the error message while submitting some forms has been identified and a hotfix will be issued within the next hour.
Posted May 10, 2022 - 09:52 EDT

Investigating

We are currently investigating an issue where some users are reporting receiving "An unexpected error has occurred" while using the SafetyAmp search bar or in some cases, when submitting a form.
Posted May 10, 2022 - 09:32 EDT
This incident affected: Application.