It appears that Google has remediated the Storage outage and delivery of the SafetyAmp service and access to your uploaded files has been fully restored.
Thank you for your patience!
Posted Jun 12, 2025 - 17:23 EDT
Investigating
Google has reported an outage with its Storage service which SafetyAmp utilizes to deliver your uploaded files to you.
While their service is experiencing this issue, your photos and uploaded documents in SafetyAmp may be unavailable.
When Google restores service, access to such documents should be immediately available again.
No failover options are available to us at this time, we are awaiting Google to remediate and apologise for the inconvenience this may cause to your operations.
Posted Jun 12, 2025 - 15:07 EDT
This incident affected: Application, SafetyAmp API and Infrastructure (Google Cloud Platform Google Cloud Storage).