Training content availability issue

Incident Report for SafetyAmp

Resolved

The issue has been identified and fixed. Refresh your SafetyAmp page to receive the update.
Posted Jan 05, 2024 - 08:47 EST

Investigating

We are investigating reports of third-party training content being unavailable and document previews not loading content.
Posted Jan 05, 2024 - 08:34 EST
This incident affected: Application.