EU Region - Partial SSO outage affecting some accounts

Incident Report for SafetyAmp

Resolved

Single Sign On service has been restored to the affected EU-region subscribers.
Posted Aug 18, 2025 - 09:22 EDT

Investigating

Our engineering team is investigating reports of SSO outages affecting a subset of EU region SafetyAmp infrastructure.
Posted Aug 18, 2025 - 08:54 EDT