Frozen Application Issue

Incident Report for SafetyAmp

Postmortem

After further investigation by our engineering team, we identified and resolved a bug that was introduced unexpectedly causing some users to see a blank SafetyAmp page. This issue should now be fully remediated, requiring no action by your users other than potentially refreshing their SafetyAmp page.

Posted Jun 26, 2025 - 13:24 EDT

Resolved

We have received reports that some users are getting a white page when accessing SafetyAmp. It seems that an update this morning intended to mitigate an early logout issue may have caused this problem. If you're experiencing it, use your web browser settings to clear cache and delete cookies to mitigate the problem.

Our engineering team is exploring options to mitigate without the above for users experiencing this issue.
Posted Jun 26, 2025 - 12:31 EDT
This incident affected: Application and SafetyAmp API.