SafetyAmp Outage

Incident Report for SafetyAmp

Resolved

The outage has been resolved for normal SafetyAmp operations. We are actively monitoring our infrastructure for any residual issues.
Posted Oct 19, 2021 - 09:44 EDT

Investigating

We are currently investigating an outage with our US-Central data center.
Posted Oct 19, 2021 - 09:34 EDT
This incident affected: Application and SafetyAmp API.