Normal operations and performance have continued since our last update, we are considering this issue resolved.
Posted Oct 04, 2022 - 13:50 EDT
Monitoring
Our team has mitigated an issue with Google Cloud infrastructure under high load causing very long load times in the application. Performance has been restored and we will continue monitoring our solution.
Posted Oct 04, 2022 - 13:00 EDT
Investigating
We are aware of an issue with the SafetyAmp application experiencing very slow load performance. Our team is currently investigating these reports.
Posted Oct 04, 2022 - 12:38 EDT
This incident affected: Application and SafetyAmp API.