This maintenance period has now been closed. Thank you for your patience.
Posted Oct 05, 2022 - 10:22 EDT
Investigating
Related to issues yesterday our team is performing some needed immediate maintenance on our application infrastructure. We hope to complete this within the next twenty minutes.
Posted Oct 05, 2022 - 10:14 EDT
This incident affected: Application and SafetyAmp API.