Some SafetyAmp Apps records are not loading

Incident Report for SafetyAmp

Resolved

This incident has been resolved.
Posted May 25, 2022 - 09:31 EDT

Investigating

Our engineering team is currently investigating an issue where some records in SafetyAmp Apps are not loading in the web application. We believe this is due to a host of cybersecurity upgrades made to our infrastructure last evening; mitigation is expected within the hour.
Posted May 25, 2022 - 08:43 EDT
This incident affected: Application.