Form submission button not always visible

Incident Report for SafetyAmp

Resolved

A fix for this issue has been deployed. If the issue persists, please refresh your SafetyAmp page and try again.
Posted Sep 29, 2022 - 09:21 EDT

Identified

This issue has been identified and our engineering team is working towards delivery of a hotfix as soon as possible. This issue is affecting only forms that contain "check all that apply" questions.
Posted Sep 29, 2022 - 08:34 EDT

Investigating

We are investigating multiple reports of the submit button for audit/inspection forms not being visible at the appropriate time. Our engineering team is urgently looking into these reports to restore normal operations.
Posted Sep 29, 2022 - 08:17 EDT
This incident affected: Application.