SDS Search Outage

Incident Report for SafetyAmp

Resolved

Partner has resolved the issue.
Posted Aug 01, 2025 - 11:07 EDT

Identified

We are working with our SDS Partner to resolve issues that surfaced today currently preventing our clients from searching for SDS in the SafetyAmp SDS Management module.
Posted Aug 01, 2025 - 10:45 EDT
This incident affected: Infrastructure (SDS Search).